We've continued to see sustained performance from Cloudflare, so we're marking this incident as closed. We'll continue to closely monitor throughout the day. As ever, if you need any support or have any questions, please contact us at support@spektrix.com.
Posted Dec 05, 2025 - 11:16 GMT
Monitoring
Systems are now accessible, and we can now access emails and phone calls. We'll continue to monitor the situation closely and post any updates here if the situation changes.
Posted Dec 05, 2025 - 09:13 GMT
Update
Due to this outage, we are unable to access our Support Emails or accept phone calls, although the phone line does appear to be open we can't see these coming through.
Posted Dec 05, 2025 - 09:05 GMT
Identified
The Spektrix System (client system, iframes, API) are currently inaccessible due to a current Cloudflare outage. We're monitoring the situation and will keep you updated here with updates as we get them.
Posted Dec 05, 2025 - 08:58 GMT
This incident affected: Support Services (Support Centre and support@spektrix.com, Phone Service - UK/Ireland, Phone Service - North America), APIs (APIs - UK and Ireland, APIs - US and Canada, APIs - Australia and New Zealand), and Spektrix System (UK and Ireland, US and Canada, Australia and New Zealand).