Some clients experiencing system slowness
Incident Report for Spektrix
Resolved
We are continuing to see improvement in system slowness across affected client systems that started at 19:00 BST / 14:00 EST today and are resolving this issue. We will continue to monitor the fix we have in place.
Posted Nov 07, 2024 - 21:17 GMT
Monitoring
We have implemented a fix and are seeing system slowness improve across affected client systems.

We will continue monitoring systems while this fix is in place.
Posted Nov 07, 2024 - 20:54 GMT
Investigating
We are aware of an issue with system slowness across some client systems that started around 19:00 BST / 14:00 EST. We believe we have identified the issue and are working to implement a solution.
Posted Nov 07, 2024 - 20:37 GMT
This incident affected: Spektrix System (UK and Ireland, US and Canada).