Since experiencing the system slowness and error screens that some of you experienced this morning, we've continued to see system speeds remain stable and we're confident that system issues have been resolved. To further understand the root cause of the slowness, we're in active conversation with one of our service providers, Microsoft. We'll continue working with them to investigate and take any necessary steps to prevent reoccurrence.
Posted Jun 04, 2025 - 14:24 BST
Monitoring
System slowness and error screens happened between 10:48 - 10:55 BST. Speeds have continued to remain as expected and we're continuing to monitor the system closely. If you have any questions or need support with anything, please don't hesitate to reach the our team at support@spektrix.com !
Posted Jun 04, 2025 - 11:14 BST
Update
We're seeing system speeds come back to normal and a reduction in error screens whilst we continue our investigations - we'll continue to update here with our progress.
Posted Jun 04, 2025 - 11:03 BST
Investigating
We're aware and investigating reports of slowness clicking around the system and error screens. We'll keep you updated as we know more.
Posted Jun 04, 2025 - 10:56 BST
This incident affected: Spektrix System (UK and Ireland).