Intermittent slowness processing chip and pin transactions - UK/IE Opayo

Incident Report for Spektrix

Update

We are continuing to investigate these reports of slowness processing C&P payments and are in dialogue with Opayo. If you are experiencing issues please contact support. It will help to have log files and where possible a video recording of the slowness.
Posted Mar 19, 2026 - 17:10 UTC

Update

We are remaining in dialogue with Opayo and reviewing all possibilities that could be causing these issues. If you are experiencing problems we will likely need to request some further information from you including log files from the pin pad, if this is the case we will contact affected users directly.

We'll continue to update here with any progress on the issue.
Posted Mar 19, 2026 - 15:43 UTC

Investigating

We are investigating reports that there is intermittent slowness affecting chip and pin transactions on the Opayo payment provider in the UK and Ireland.

The slowness is happening after the user selects to pay by chip and pin and causes a delay in the payment information loading on the card reader. Other aspects of payment processing across all payment providers are functioning normally.

We are in dialogue with all relevant parties to establish any potential causes of the problem and will update when we hear more.
Posted Mar 19, 2026 - 15:10 UTC
This incident affects: Payments Processing (Opayo (formerly SagePay)).