System Slowness
Incident Report for Spektrix
Resolved
We are confident this issue is now resolved and the Spektrix system is performing as expected.

If you experience any issues please get in touch with our Spektrix Support Team at support@spektrix.com or +1 (646) 569-9097. Thank you for your patience as we worked to resolve this issue.
Posted Sep 05, 2024 - 22:07 BST
Monitoring
We believe we have implemented a fix and are seeing improved click speeds in the Spektrix system and on websites.

We will continue to monitor the situation and will update here with any further information.
Posted Sep 05, 2024 - 21:16 BST
Identified
We have narrowed down the cause to one of our database pools. This is causing system slowness that is also impacting websites since about 3:15pm EST / 8:15pm BST for clients in North America, the United Kingdom, and Ireland.
Posted Sep 05, 2024 - 20:53 BST
Investigating
We are aware that some clients across North America, the United Kingdom, and Ireland may be experiencing some system slowness that is also impacting websites since about 3:15pm EST / 8:15pm BST. We are investigating the issue now and will post updates accordingly.
Posted Sep 05, 2024 - 20:35 BST
This incident affected: Spektrix System (UK and Ireland, US and Canada).